tis-ms-rktools 6.0.2600.0-1

  • package : tis-ms-rktools
  • version : 6.0.2600.0-1
  • architecture : all
  • locale :
  • description : Microsoft Resource kit tools for Windows Server 2003
  • maintainer : technique@tranquil-it-systems.fr
  • date : 2018-02-27 19:04:11
  • min_wapt_version :
  • min_os_version :
  • max_os_version :
  • impacted_process :

setup.py

# -*- coding: utf-8 -*-
from setuphelpers import *

# registry key(s) where WAPT will find how to remove the application(s)
uninstallkey = ['{FA237125-51FF-408C-8BB8-30C2B3DFFF9C}']

# command(s) to launch to remove the application(s)
uninstallstring = []

# list of required parameters names (string) which can be used during install
required_params = []


def install():
    # if you want to modify the keys depending on environment (win32/win64... params..)
    global uninstallkey
    global uninstallstring

    print('installing tis-ms-rktools, Microsoft Resource kit tools for Windows Server 2003')
    run(r'msiexec /qn /i rktools.msi')

    

Changelog

No changelog
    

manifest.sha256

WAPT/certificate.crt 79e5388683c0b6cb03f4f81e4e58e3a11463b2b6cf169dd9c453098027dcfaa4
WAPT/wapt.psproj 798d3fe459b24e0460ace5be62ed6f6a46b3628442db63889ed4697c27047eb6
rktools.msi 8008be1641f462f18b58d198fd32eb879a21bade78aaae20490a0ed98d5acecf
WAPT/control 84af54027fd8b1d149aab03443d93f1ab6cf75be9e36a0b6b00a539178cf7f2c
rktools_s.cab 30d6c672590fa588187b8c85aa273fbbf24425debc5c0a98d1b64e01a59ddd9e
setup.py 0b6b8c59781b4dcf99d82212466b35412b97c907908f5fb0dfad5f5c296f6703
rktools_p.cab 569d8de6b2dda76787863db6d4dddf48aaae4dd0d5f23fa00331deef4b837cce

Forum feed

WAPT Packages / Paquets WAPT • Re: Creation d'un paquet WAPT Cleaner
Bonsoir Renaud,
renaud.counhaye a écrit :
15 octobre 2018, 12:08
J'ai effectuer une migration de serveur WAPT, des machines sur serveur "A" WAPT 1.3 vers serveur "X" WAPT 1.5 (qui as ensuite été update en 1.6)

Soucis de cette migration est que les machines ayant subis le changement via waptdeploy on ramener leur inventaire du 1.3 vers le 1.5 et certains noms de paquet on changer, d'autres paquet disparu.
Pourtant leur inventaire reste valide au yeux du client et a la barbe de la console.
Du point de vu du poste, celui-ci est bien à jour : il n'y a pas de paquet plus à jour que celui qui est déjà installé sur la machine. Donc ce n'est pas incorrect, même si ce n'est pas exactement ce que vous vouliez.
renaud.counhaye a écrit :
15 octobre 2018, 12:08
J'aimerais un coup de main pour créer un script de nettoyage savoir si vous auriez mieux a proposer que ceci:
Si il n'y a pas trop de package impactés, vous pouvez juste taper le nom du paquet en question dans textbox de recherche ("search keyword"), par exemple xyz-firefox, et les machines qui ont le paquet en questions vont être listées. Note: attention, la recherche matche en substring, donc xyz-firefox en recherche retournera aussi les machines ayant xyz-firefox-esr).
  • Ensuite vous sélectionnez "supprimer des dépendances de paquets ou de groupes de paquets" pour supprimer la dépendances sur les paquets en question;
  • puis vous supprimer ou oublier le paquet en sélectionnant les machines concernées et, dans la liste de paquets sur la droite, faites bouton droit et "oublier des paquets"
Cordialement,

Denis

Statistiques: Posté par dcardon — 15 octobre 2018, 20:12


WAPT Packages / Paquets WAPT • Creation d'un paquet WAPT Cleaner
Salut la compagnie :)

J'ai effectuer une migration de serveur WAPT, des machines sur serveur "A" WAPT 1.3 vers serveur "X" WAPT 1.5 (qui as ensuite été update en 1.6)

Soucis de cette migration est que les machines ayant subis le changement via waptdeploy on ramener leur inventaire du 1.3 vers le 1.5 et certains noms de paquet on changer, d'autres paquet disparu.
Pourtant leur inventaire reste valide au yeux du client et a la barbe de la console.

J'aimerais un coup de main pour créer un script de nettoyage savoir si vous auriez mieux a proposer que ceci:

Le script run un wapt-get list puis a l'aide d'une boucle je cherche les exception que j'aurais listée plus tot dans une var.
Si je trouve le paquet, un simple wapt-get forget xxxxxx puis un wapt-get install zzzzz avec le paquet remplacant.

Peut être ais-je rater un step dans le waptdeploy pour nettoyer post ou pre install. Ou peut être quriez vous une sorte de paquet déjà disponible pour un procéder similaire?

Merci d'avance :)

(je vais probablement avancer sur le système citer ci dessus et vous le partagerais une fois finis)

Statistiques: Posté par renaud.counhaye — 15 octobre 2018, 12:08


WAPT Packages / Paquets WAPT • Error line 3512 in install_wapt
Bonjour à tous,

Depuis la mise à jour vers WAPT 1.6 j'ai le paquet 7zip qui a tendance a fail a l'installation avec cette sortie :

uninstalling 7-Zip 9.20 (x64 edition)
Traceback (most recent call last):
File "c:\wapt\common.py", line 3512, in install_wapt
exitstatus = setup.install()
File "c:\windows\temp\wapt6e8_dt\setup.py", line 42, in install

le code du paquet pyhton de wapt.lesfourmisduweb.org :

CODE :

def install():    global uninstallkey    from common import Wapt    broken_7zip = [ soft for soft in installed_softwares('7-zip') if Version(soft['version']) < Version('16.0') ]    if broken_7zip:        for uninstall in broken_7zip:            cmd = WAPT.uninstall_cmd(uninstall['key'])            print(u'uninstalling %s' % (uninstall['name'],))            # on execute la commande de desinstallation            run(cmd)    allmsi = glob.glob('*-x64.msi')    for msi in allmsi:        if iswin64():            install_msi_if_needed(msi,killbefore=['7zFM.exe'])        else:            install_msi_if_needed(msi.replace('-x64.msi','.msi'),killbefore=['7zFM.exe'])    for ext in ('.001','.7z','.arj','.bz2','.bzip2','.cab','.cpio','.deb','.dmg','.fat',            '.gz','.gzip','.hfs','.iso','.lha','.lzh','.lzma','.ntfs','.rar','.rpm',            '.squashfs','.swm','.tar','.taz','.tbz','.tbz2','.tgz','.tpz','.txz','.vhd',            '.wim','.xar','.xz','.z','.zip', '.zipe'):        register_ext('7-zip',ext,'"%s" "%%1"' % (makepath(programfiles,'7-zip','7zFM.exe'),),icon="%s,1" % (makepath(programfiles,'7-zip','7z.dll')))""" You can do a CTRL F9 in pyscripter to update the package """
Dans le doute je vais juste pas garder ça et remplacer avec simplement :

CODE :

if iswin64():        install_msi_if_needed('7z1805-x64.msi',killbefore=['7zFM.exe'])    else:        install_msi_if_needed('7z1805.msi',killbefore=['7zFM.exe'])    for ext in ('.001','.7z','.arj','.bz2','.bzip2','.cab','.cpio','.deb','.dmg','.fat',            '.gz','.gzip','.hfs','.iso','.lha','.lzh','.lzma','.ntfs','.rar','.rpm',            '.squashfs','.swm','.tar','.taz','.tbz','.tbz2','.tgz','.tpz','.txz','.vhd',            '.wim','.xar','.xz','.z','.zip', '.zipe'):        register_ext('7-zip',ext,'"%s" "%%1"' % (makepath(programfiles,'7-zip','7zFM.exe'),),icon="%s,1" % (makepath(programfiles,'7-zip','7z.dll')))
Mais peut être qu'un oeil expert trouveras le bug :)

Cordialement,
Renaud

Statistiques: Posté par renaud.counhaye — 15 octobre 2018, 11:28


WAPT Packages / Paquets WAPT • Re: Installation Flash en erreur sur certains postes
Bonjour PPE,
PPE a écrit :
12 octobre 2018, 15:23
Maintenant que mon souci de mise-à-jour du serveur WAPT est résolu, je peux revenir à ce problème.

En définitive, je n'arrive pas à lancer la commande "sc.exe sdshow AdobeFlashPlayerUpdateSvc"
En effet, je reçois le message "access denied". A noter que je suis bien connecté en administrateur du poste et que je lance cmd.exe avec l'option "run as administrator..."

J'imagine que le message d'erreur reçu lors de l'installation du paquet flash vient de là mais pourquoi ne puis-je pas lancer la commande sc.exe sur ces postes ?
est ce que le service est bien listé dans services.msc? Est ce que vous pourriez vérifier les droits d'une manière graphique sur ce service si il existe.

Lors de l'installation du paquet Flashplayer, le paquet supprime le service d'auto-mise à jour si il existe. Ici le problème semble être un Sécurity Descriptor incorrect...

Quand vous avez une commande qui plante, il est beaucoup plus utile de fournir exactement la ligne de commande et sont retour dans des bloc "code". Ca permet aussi d'avoir le code de retour et d'autres information.

Cordialement,

Denis

Statistiques: Posté par dcardon — 12 octobre 2018, 17:52


WAPT Packages / Paquets WAPT • Re: [RESOLU] Erreur tis-java8

CODE :

                              if isdir(makepath(programfiles64,'Java','jre' + get_msi_properties(msi)['JDK_VERSION'])):                        killalltasks('iexplore.exe')                        killalltasks('jushed.exe')                        remove_tree(makepath(programfiles64,'Java','jre' + get_msi_properties(msi)['JDK_VERSION']))
J'avais intégré ceci dans mon code pour wapt java, je ne l'ai pas mis sur le store tis, j'avais un peu peur des effets de bord

Statistiques: Posté par sfonteneau — 05 octobre 2018, 21:14