tis-fusioninventory 2.3.17-2

  • package : tis-fusioninventory
  • version : 2.3.17-2
  • description : Outil d'inventaire FusionInventory pour GLPI. Note : le client est configure pour se connecter a un hote s'apellant "glpi". Il faut donc faire un CNAME ou modifier le fichier .py
  • maintainer : Jeremie, Amelie LE JEUNE
  • date : 2017-07-20 15:52:53
  • signer : TRANQUIL IT SYSTEMS
  • signature_date : 20170720-155253
  • min_os_version :
  • min_wapt_version :

setup.py

# -*- coding: utf-8 -*-
# -----------------------------------------------------------------------
#    This file is part of WAPT
#    Copyright (C) 2013  Tranquil IT Systems http://www.tranquil.it
#    WAPT aims to help Windows systems administrators to deploy
#    setup and update applications on users PC.
#
#    WAPT is free software: you can redistribute it and/or modify
#    it under the terms of the GNU General Public License as published by
#    the Free Software Foundation, either version 3 of the License, or
#    (at your option) any later version.
#
#    WAPT is distributed in the hope that it will be useful,
#    but WITHOUT ANY WARRANTY; without even the implied warranty of
#    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
#    GNU General Public License for more details.
#
#    You should have received a copy of the GNU General Public License
#    along with WAPT.  If not, see <http://www.gnu.org/licenses/>.
#
# -----------------------------------------------------------------------
from setuphelpers import *

# registry key(s) where WAPT will find how to remove the application(s)
uninstallkey=['FusionInventory-Agent']

def install():
    if WAPT.options.force or not installed_softwares(uninstallkey[0]):
        if iswin64():
            print "Installation FusionInventory 64bits"
            install_exe_if_needed('fusioninventory-agent_windows-x64_2.3.17.exe', '/S /acceptlicense /server="http://glpi/glpi/plugins/fusioninventory/" /execmode=service /no-ssl-check /runnow' , min_version='2.3.17')
        else:
            print "Installation FusionInventory 32bits"
            install_exe_if_needed('fusioninventory-agent_windows-x86_2.3.17.exe', '/S /acceptlicense /server="http://glpi/glpi/plugins/fusioninventory/" /execmode=service /no-ssl-check /runnow' , min_version='2.3.17')
    else:
        print "FusionInventory deja installe"

    

manifest

[["WAPT/icon.png", "a5e007a409c6219c95e743d05ef12123a6f140a4"], ["WAPT/certificate.crt", "0db563dc9077b268ca07ba834322d0fc5e21f8e5"], ["WAPT/wapt.psproj", "4e85d7af350c7aa022303492501577e1436625bd"], ["fusioninventory-agent_windows-x64_2.3.17.exe", "36994cf446dfcd38bc40e71ed6288e4d24eaf83a"], ["fusioninventory-agent_windows-x86_2.3.17.exe", "b904c7a9ec2b3dd80aedfb9f1a0e4f786fab1c4f"], ["setup.py", "2369db3b90db4db0c397106dd70a0c2cedf8b671"], ["WAPT/control", "dbb88e9dddbbfcb6061ea9e06d333822ae163d83"]]